• Advertisement
Support This Site

Turn signal issue

Need help with your car? Post up your questions or requests here.

Turn signal issue

Postby hjaynes » Fri Oct 04, 2013 5:44 pm

I have a 99 93 convertible. My left rear blinker doesn't work and get the fast blink now for the front. I pulled the bulb and it appears to be fine. There was quite a bit of powder looking stuff like you'd see with a battery by the terminals. I put in another bulb but still no luck. I cleaned out where the bulb was too but no luck. Is there an actual fuse for this because I couldn't find it in the owners manual or the shop manual. All the other lights / bulbs work that I know of.

Thanks for the help!
User avatar
hjaynes
Noobie
 
Posts: 14
Joined: Mon May 07, 2012 7:42 am
Location: Florida / Washington DC

Re: Turn signal issue

Postby StrictlySaab » Sat Oct 05, 2013 4:34 pm

Check for 12v at the power lead for that circuit on the board or wire. Turn signals are fed through DICE. High resistance in a dirty connection will also cause the same fast blink. Also check circuit board ground wire for burning but those tend to lead to multiple inop lamps on the same cluster.
Strictly Saab Inc.
Melbourne, FL
P-321.432.2034
'91 900 S-PG 5spd
'06 9-3 Sport Sedan 2.0L 5spd
'99 Porsche 911 C2 Racekar 6spd
'01 Porsche 911tt 6spd
'06 Chevy 2500HD 4x4 Dmax Allison 6spd
StrictlySaab
Crazy Saaber!
 
Posts: 167
Joined: Sun Aug 24, 2008 8:26 pm
Location: Melbourne, FL

Re: Turn signal issue

Postby hjaynes » Fri Oct 11, 2013 8:22 pm

It was a dirty connection. Thank you for your response. :-)
User avatar
hjaynes
Noobie
 
Posts: 14
Joined: Mon May 07, 2012 7:42 am
Location: Florida / Washington DC


Return to Need Help?

Who is online

Users browsing this forum: No registered users and 1 guest

cron